Face mask in Face in Picture?

  • Hi, Richard Gray!

    There are few steps that need to be done:

    I am starting with "Face in picture template" 

    1. Added a Face Mask - it is rendered to Camera

    2. Then create a new render target for this Camera (Add new - Render Target on a resources panel)

    and set this newly created texture to be a render target of Camera:

    So "Camera" renders to "Render Target New", and "Orthographic camera" renders to "Render Target". 

    3. Now set "Render Target New" to be input of "Render Target" . And "Device Camera Texture" to be input of "Render Target New"

    4 And the last step will be to select Face Inset component and swap Device Texture with Render Target New 

    And here is a result : 

    Sorry, this looks like a lot, so here is a project

    Best

    Olha

     

    Comment actions Permalink
  • No, it's not a lot! This works perfectly! Thank you so much. 

    This community is the best. I'm new to most of this but I hope I can contribute in the near future just as Olha has with me. Thanks again!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!