The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Snap camera doesn't work : "no available camera unit"

  • marinosays

    There's currently a bug right now, the latest version of Zoom doesn't allow Snap Camera to work so try downgrading the version of Zoom and it should work fine, a lot of other people are having this same issue and Lens Studio and Snap Camera are aware of this situation. Zoom is looking into this bug as well.

    Comment actions Permalink
  • Thanks for the tip, I tried downgrading my Zoom to version 4.6.10., but I still got the same message. I even tried to use Snap Camera with Zoom uninstalled, but nothing changed.

    Comment actions Permalink
  • Have you tried installing the drivers? Usually that’s the issue with new computers

    Comment actions Permalink
  • Yeah I installed Driver booster and even got the pro version and updated every possible driver that could've been updated. Still, no difference at all. I'm starting to think that this is a problem related to my computer, but I only bought it a day ago. I will try to downgrade both Snap cam and Zoom, i'll post an update.

    Comment actions Permalink
  • I forgot to mention this 

    System Requirements
    • Operating System: Windows 10 (64 bit); MacOS 10.11+
    • HardwareMinimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher
    Comment actions Permalink
  • I am also having this issue with snap camera, This does not seem to be an issue with Zoom rather an issue with Snap camera, My video camera works fine and can be used by multiple other apps correctly although snap camera cannot initialize it at all, doesn't matter what I do with zoom or even if its uninstalled, I have up to date drivers, I have tried running snap camera as admin, I have checked all my privacy settings on windows (Win 10 x64 Enterprise). Snap camera just does not detect the camera.

    Comment actions Permalink
  • Found a work around:

    • Installed "ManyCam"
    • Selected camera input from "Snap Camera" settings as "ManyCam"

    Now asides from the annoying watermark it works!

    Comment actions Permalink
  • Ok I tried downgrading both Snapcamera and Zoom, still doesn't work. I hope they fix this in a future update. I'll download ManyCam though, see how that works. Again, thank you all for the tips!

    Comment actions Permalink
  • Hi,

    For resolve, turn on and turn off again "Allow desktop apps to access your camera".

    To let apps access the camera, select Start, then select Settings  > Privacy  > Camera. Under Allow access to the camera on this device, select Change, then turn on Camera access for this device.

    But below that you will find "Allow desktop apps to access your camera", turn on and turn off again. You are going to fix it!!! If doesn't works remember before turn on again close, quit or end task (from task manager) every app that use the camera. After that turn on again and run snap camera first. 👍

    GOD Bless You!!!

    Comment actions Permalink
  • where do I find start?


    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!