The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

[Example Project] Chain Physics with Two Anchors

  • Wow this is great! Such an in-depth walkthrough, thank you Olha!

    Comment actions Permalink
  • I was just about to make a post asking for exactly this. Thanks!

    Comment actions Permalink
  • Is there a way to do this with just a simple chain of spheres too - like in the Chain Physics tutorial?

    Comment actions Permalink
  • Hi, Dweeh

    Yes, this project has a setup for spheres included!

    Please look for the Test sceneObject 



    Comment actions Permalink
  • Oh...   :)  Thanks! 

    I tried to mess around with it a lot - but I can not make it do what I want.

    Is it because it is rigged that you can make your chain links stay together without space between the links?


    Comment actions Permalink
  • Hi, Dweeh!

    To achieve this please try to set type to Elastic and Iterations to 4-5 



    Comment actions Permalink
  • Project was not opened! !extractDataFiles:No data and scene file missing

    Comment actions Permalink
  • Hi, TTT!

    I just tried both on Windows and MacOS machines and it works for me. 

    I am using the most recent build from Lens Studio Website

    Could you please try again and provide more information if you still experience the issue



    Comment actions Permalink
  • Still the same error even though I am using version 2.3.1

    Comment actions Permalink
  • Hi TTT!

    Did you try to delete the file and download it again - just to make sure the file is not damaged?

    Comment actions Permalink
  • hi:Dweeh


    Yes, I deleted the file and uploaded it more than once and the problem continues

    Comment actions Permalink
  • Comment actions Permalink
  • Olha


    Do you have a example project where the chain is attached to the shoulders like a necklace would be?  

    Comment actions Permalink
  • ❤️❤️❤️

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!