The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Multiple controllers

  • Hey Tanya,

    You can watch our latest Twitch Stream which we show how to have multiple controller as well as mixing the templates together.

    You can find the stream here:


    Let me know if you still have problem with your project.



    Comment actions Permalink
  • Hi Amir

    Thank you for linking me through to the twitch stream. With the hair color template I'm still not sure what else I should be doing so that it continues to change. I feel like I am missing a step. 

    I now have 3 different controllers in my Objects panel. I then linked these controllers to their own controller in the Resources panel. Should I then duplicate the hair color provider for each color? I have tried both options and it seems to be sending me down a rabbit hole of problems. The hair color still changes for the first tap on the cans but thereafter stays stuck on one hair color. 

    Comment actions Permalink
  • Hi Tanya,

    I made a sample project with two buttons that you can use!


    Basically you need to re-run this part of HairController code on every tap, because that's where it tells HairColorProvider which settings to use. 

    I've wrapped it in separate function so it can be called using script.api on Tap from another script.

    Also no need to duplicate HairController.js or HairController object in this case. Just duplicate as many Scene Objects as you need.




    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?



Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:



What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!