All pushed lenses show "Loading"

  • Hi Don,

    Have you successfully pushed Lenses to your device before? If that was the first Lens you attempted to push, is it possible your Lens might have been pushing the memory consumption limit? Lens Studio's limit for memory consumption is a maximum of 120 MB RAM memory. The optimal RAM memory we recommend is under 100 MB and you can check memory consumption by pushing your Lens to device and clicking on the settings button as described in this guide. You can see all performance requirements in this guide here.

    If you do meet all of the performance requirements, which version of Lens Studio are you running? Have you downloaded the latest version yet?

    Cheers,

    Karolina

    Comment actions Permalink
  • Hi Karolina, thanks for the response, I appreciate you taking the time to assist me.

    No, I have never successfully loaded a lens that has been pushed (they get pushed, they just don't load). 

    As I said, I'm only using one of the templates provide by Lens Studio, and have not made any changes to it. I've tried four of the examples. When pushed to my phone, the lens won't load, so there is no way to view how much memory it is using. I'd assume all of the example templates meet the memory requirements.

    I get a prompt on the phone saying it has arrived, the computer says it was pushed, I see a new lens selection in the SnapChat app, but it won't open. It only shows the "Loading..." text.

    I'm running version 2.0.0.1 of Lens Studio. My computer easily meets the minimum requirements to run it. 

    My phone is a Samsung Galaxy S7 Edge, running Android 8.0.0

    Any ideas?

    Comment actions Permalink
  • Hi Don,

    I'll follow up with you via email to get this resolved quickly!

    Cheers,
    Karolina

    Comment actions Permalink
  • Karolina - 

    I think I'm having the same problem as Don here. I have the latest Mac Lens studio app. My Snapchat app on my Galaxy S9 is up to date but when I try to pair it just gets stuck on "Loading..." not just the lens I'm working on now but also old Lenses that previously previewed fine.  

    Any thing I can do to fix this?

    Thanks!

    Andrew

    Comment actions Permalink
  • Hi, 

    I'm having the exact same problem with the same config than Andrew Piinzler has. That happened since I updated Lens Studio to the v2. 

    It doesn't work whatever the lens I push to my device. An old one, an empty new one, a new template...

    All my setup is up to date. I share it just in case : 


    - MacBook Pro 2015 v10.14.4

    - Lens Studio 2.0.0.2

    - Galaxy S9 

    - Snapchat v10.57.4.0 Beta

    Comment actions Permalink
  • Hi All,

    Please try the following:

    1. Logout from Snapchat on the phone
    2. Use Main Menu > Pairing > Disconnect in Lens Studio


    If this does not help,

    On desktop:

    1. Go to Keychain
    2. Find record com.Snap.LensStudio.UUID by searching Lens Studio
    3. Remove key


    Please let me know if that helps!

    Cheers,
    Karolina

    Comment actions Permalink
  • Hey all,

    Logout from Snapchat and unpair my phone from Lens Studio has solved the issue for me!

    The only thing I noticed is I had to restart Lens to succeed to pair my phone.

    All of my previous and new lenses work well and can be pushed on my phone! 

    Thanks!

    Comment actions Permalink
  • Hey, 

    If anyone else comes across this I had to do the same as Boulay above and delete the UUID from keychain

    Thanks!

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!