The forum on this site is closed for new comments and posts. Continue the conversation in the new forum, and learn more here.

Having trouble with texture on one specific piece of my model.

  • Hello Cemo8785,

    I don't think the texture problem is related to the Posemorph tag.

    First please make sure the texture resolution is less than a 2048x2048.

    Then, please make sure when you are exporting to check the "Embed Textures" check box in the FBX Export Settings.

    And the last thing is make sure that you are not using procedural materials and you bake your texture not your object, also make sure to set your baked texture as a "Color" in Cinema 4d. 

    Hope this will help you to fix your problem.

    Best,

    Amir.

    Comment actions Permalink
  • Hi Amir,

    I have checked all of those settings and I'm still having the same problem. Do you know why it's only the eyelid that has this problem? The eyeball and eyelid are two different shapes. The texture on the eyeball has no problems. It's only the texture on the eyelid that has problems. And the only thing I can think of that is different between the two is the posemorph/subdivision surface on the eyelid. But I made the object editable so the subdivision surface effect shouldn't be affecting it. 

    Comment actions Permalink
  • Hey Cemo,

    Is it possible for you to share the model c4d file and FBX file so I can investigate.

     

    Best,

    Amir.

    Comment actions Permalink
  • Comment actions Permalink
  • Hey Cemo,

    I just opened your file and realized when you disabled your object in C4D and import the file into Lens Studio it wont be disable any more and it will import as an enabled object.

    So all you need to do is to disable your eye pos object in Lens Studio by unchecking the "Poses__best_eyelid" object in the Objects panel.

    Those pink material is an indicator to show you that your object does not have a texture assign to the material.

    Hope this will fix your problem and have fun creating lenses.

    Best,

    Amir.

    Comment actions Permalink
  • Ahhh I see. I just opened this in Lens Studio and it looks like that worked. Thank you so much Amir!

    Comment actions Permalink
  • Hi Amir, I just noticed that this causes a problem. When that box is unchecked it changes the animation. The eyeball should not be showing through the eyelid as it does when you uncheck it. I think it has something to do with the blending of poses/shapes. Do you have any idea how to fix this problem?

     

    edit: I think this problem existed before the texture problem. But I'm still not sure how to solve it.

    Comment actions Permalink
  • Hey Cemo8785,

    You can keep your blend-shapes enabled but move them far away from the camera so it wont be visible in the lens.

     

    Let me know if that helps.

    Best,

    Amir.

    Comment actions Permalink

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!