Different Audios for Rear camera and Front Camera?

  • Hi Jimmi,

    your pseudocode is 100% correct. I would suggest you start tackling the issue in a more "Lens Studio way".

    Write two scripts, where one plays the front and one the back mp3.

    Then check the script events page and scroll to Camera Events.

    Add the two scripts to the corresponding parent object of your lens and let one be triggered on 'Switched To Front' and the other on 'Switched To Back' Camera.

    Good luck and feel free to ask any further questions.

    Cheers,
    Luka

    Comment actions Permalink
  • Thanks, Luka, I will post code when it's ready!

    Comment actions Permalink
    1. In Object Window: create Scene Object "AudioManager"
    2. In Resources Window: create script "PlaySeparateAudio"
    3. In Resources Window: add front.mp3 and back.mp3
    4. In Object Window: select `AudioManager`
    5. In Inspector: add two audio components to `AudioManager`
    6. In Inspector: add Script Component. Select `PlaySeparateAudio.js` 
    7. In Inspector: select each Audio Component for `AudioFront` and `AudioBack` values

    PlaySeparateAudio.js:

    // Play Audio
    // @input Component.AudioComponent audioFront
    // @input Component.AudioComponent audioBack

    var event = script.createEvent("CameraFrontEvent");

    event.bind(function (eventData)
    {
    print("front camera active");
    script.audioFront.play( 1 );
    script.audioBack.stop( true ); // fade
    });

    var event2 = script.createEvent("CameraBackEvent");

    event2.bind(function (eventData)
    {
    print("back camera active");
    script.audioBack.play( 1 );
    script.audioFront.stop( true ); // fade
    });

    Thanks!

    Comment actions Permalink
  • Yo Jimmi,

    glad to see you figured it out and so cool of you to share it for future reference.

    Cheers,
    Luka

    Comment actions Permalink
  • Great script Jimmi! Thanks for sharing :D

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!