reflective eyes

  • Hi Austin, we should be able to get this working. 

    • First, create a new Face Mask Default material. In the Resources panel, select Add New -> Material -> Component Defaults -> Face Mask
    • Select your new Face Mask Default material and change it's Base Texture to your black eye texture
    • Also, enable Simple Reflection in the material and set it to an image you'd like it to reflect. For example, the "echopark_spec" image that comes with the default project. Tune the intensity (lower is probably better)
    • Now create a new Face Mask. In the Objects panel, select Add New -> Face Effects -> Face Mask
    • Assign the Face Mask's material to the Face Mask Default material you created

    Note, if you want something more like Spherical reflections, you probably should use a 3D model of a sphere with a PBR material to drive the reflections. But the above might be able to accomplish what you're looking for. 

    Comment actions Permalink
  • i can't seem to find an option about simple reflect or how to use any material properties 

     

    Comment actions Permalink
  • You need to select the newly created material in the Resources panel. With it selected, you should see a number of options in the Inspector panel that you can tune. About halfway down, there is a checkbox called "Simple Reflection". 

    Comment actions Permalink
  • okay so that worked. It looks terrible. Using a model and pbr would be best but when i tried that, the mesh would stay while the eye lids were closed. Any other idea's?

     

    Comment actions Permalink
  • Hi Austin,

    You can use a Face Mask to cover up the parts of the eye mesh you don't want to show.

    First, add the two eye meshes. It sounds like you've already done this part but I'll include it just in case. You can skip to the next section if you just want to set up the face mask.

    • First, create a head binding by going to Add New > Face Effects > Head Binding. Remove the Face Occluder object underneath it (right click and select "Remove").
    • Set the binding's attachment point to "Left Eye".
    • Add a child mesh object by selecting the head binding object and clicking Add New > Mesh > Empty
    • On the new mesh object's Mesh Visual, change the "Mesh" property to the eye mesh you want to use. You can just use the built in "Sphere" mesh if you don't have your own.
    • Change the Mesh Visual's Material 1 to the eye material you want to use.
    • Scale the object to roughly fit the size of an eye. I used the default Sphere mesh and scaled the object to about (0.23, 0.23, 0.23).
    • Now, select the head binding object and duplicate it (right click and select "Duplicate"). On the new copy, change the attachment point to "Right Eye".
    • You should now see two meshes being drawn over your eyes (and above your face around them)

     

    Now it's time to set up the face mask. This Face Mask will use your actual face as its texture and draw above the eye meshes created earlier, masking out the parts we don't want to show.

    • First, create a face mask using Add New > Face Effects > Face Mask. 
    • Select the new face mask and make sure "Use Orig. Face" is checked.
    • Change the face mask's Texture to Device Camera Texture. This is important so make sure it's right!
    • Now you need to find or make an opacity texture that covers the area around the eyes, but not the eyes themselves. I went to the "Photo" template and grabbed the "eye_1" texture found in the "Opacity Textures" folder. This one works pretty well but isn't perfect, since there's a little too much opacity fading around the eyelids. You can edit the texture in image editing software to adjust this.
    • On the face mask, set "Opacity Texture" to the opacity texture you just brought in.
    • You should now see your eye meshes visible between your eyelids, with the face mask covering over the rest of your face. If the eye meshes are completely visible and drawing over your face, make sure the face mask is below them in the hierarchy. My hierarchy looks like this at the end:

    Hope this helps! Let me know if you have any more questions.

    Comment actions Permalink
  • that would probably work great. The opacity texture is a smart idea! i don't have a opacity textures folder though. I only have a PBR folder. Is there somewhere i can download it for future reference? i see them use it here https://lensstudio.snapchat.com/templates/face/photo/ and i don't have it when i look there, or anywhere else.  

    Comment actions Permalink
  • In Lens Studio, you can go to File > New Project From Template > Face > Photo to open up the Photo template.
    Or, from the starting screen you can go to the "Templates" tab and then open the Photo template from there (it should be near the top of the Face templates).

    Once you have the template project open, save it as a new project. Now that the project is saved, you can access any of the textures by looking in the "Public" folder in your project directory. Here's a quick way to do that:

    • Expand the "Opacity Textures" folder in the Resources panel
    • Right click on any of the textures inside
    • Click "Show in Finder" if on OSX, or the equivalent on Windows

    This should open up the folder containing all the textures. From here you can just switch back to your main project and import whichever textures you want.

    Comment actions Permalink
Have a comment?

Please sign in to leave a comment.

We're here to help! We just need a little bit of information...

What system are you using?

Have you downloaded the latest version of Lens Studio?

Please download the latest version of Lens Studio. If you still run into this issue, please come back and report it!

Is this issue causing Lens Studio to crash?

What system do you run Lens Studio on?

Version

Graphics

Follow the next steps to help us solve your issue:

  • Copy and paste this text into your TerminalCommand Window
    open ~/Library/Preferences/Snap/Lens\ Studio/ %LOCALAPPDATA%\Snap\Lens Studio Copy Text
  • Press ReturnEnter to run the command. The Lens Studio folder will automatically open
  • Prepare to upload your files: zip the "Log" Folder by right-clicking and choosing "compress."
    Locate the Log.txt file right above it.

    Attach a screenshot of the issue:

Name:

Email:

What is this most relevant to?

Please enter a brief description of your issue:

Thanks for submitting this issue.

Unfortunately, it's likely due to the operating system or hardware you're using – since they don't meet the system requirements for Lens Studio.

Still, we hear you loud and clear, and are logging the issue in case there's ever a workaround we can provide!

Minimum Requirements

Operating System: Windows 10 (64 bit); MacOS 10.11+

Hardware: Minimum of Intel Core i3 2.5Ghz or AMD Phenom II 2.6Ghz with 4 GB RAM; Intel HD Graphics 4000 / Nvidia GeForce 710 / AMD Radeon HD 6450 or better; screen resolution of 1280x768 or higher

We'll try to resolve this issue as soon as possible. Thanks for letting us know about it!

Keep an eye out for a followup email from us. We may have a couple more questions for you, or we might already have a solution to offer.

Happy creating!